IS-IS and OSPF Redistribution (Configuration Example on Nexus 9K)

Topology


OSPF and ISIS Initial Configuration

NX01:

NX01# show run int ethernet 1/1

version 9.3(9) Bios:version

interface Ethernet1/1
  no switchport
  ip address 172.31.10.1/30
  ip router isis 10
  no shutdown


NX01# show run int lo1

interface loopback1
  ip address 10.1.1.1/32
  ip router isis 10


NX01# show run | sec isis
router isis 10
  net 11.1111.1111.1111.1111.00
  is-type level-1
  address-family ipv4 unicast


NX02:

NX02# show run int ethernet 1/1-2

version 9.3(9) Bios:version

interface Ethernet1/1
  no switchport
  ip address 172.31.10.2/30
  ip router isis 10
  no shutdown

interface Ethernet1/2
  no switchport
  ip address 192.168.20.1/30
  ip ospf authentication message-digest
  ip ospf authentication key-chain learnduty
  ip router ospf 10 area 0.0.0.0
  no shutdown

key chain learnduty
  key 1
    key-string cisco

feature ospf

router ospf 10
  router-id 1.1.1.1
  area 0.0.0.0 authentication message-digest

router isis 10
  net 11.1111.2222.2222.2222.00
  is-type level-1
  address-family ipv4 unicast


NX03:

interface Ethernet1/2
  no switchport
  ip address 192.168.20.2/30
  ip ospf authentication message-digest
  ip ospf authentication key-chain learnduty
  ip router ospf 10 area 0.0.0.0
  no shutdown

interface loopback1
  ip address 10.2.2.2/32
  ip router ospf 10 area 0.0.0.0


key chain learnduty
  key 1
    key-string cisco

feature ospf

router ospf 10
  router-id 2.2.2.2


OSPF and ISIS Redistribution

  • Redistribute IS-IS into OSPF:

router ospf 10
  redistribute isis 10 route-map 20

route-map 20 permit 10
  match ip address prefix-list 20
ip prefix-list 20 seq 15 permit 10.1.1.1/32


  • Redistribute OSPF into IS-IS:
router isis 10
  address-family ipv4 unicast
    redistribute ospf 10 route-map 30

route-map 30 permit 10
  match ip address prefix-list 30
ip prefix-list 30 seq 5 permit 10.2.2.2/32


Verifications

On NX01, we can see that 10.2.2.2/32 was redistributed from OSPF to IS-IS:

NX01# show ip route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>

10.1.1.1/32, ubest/mbest: 2/0, attached
    *via 10.1.1.1, Lo1, [0/0], 02:05:45, local
    *via 10.1.1.1, Lo1, [0/0], 02:05:45, direct
10.2.2.2/32, ubest/mbest: 1/0
    *via 172.31.10.2, Eth1/1, [115/50], 00:00:17, isis-10, L1
172.31.10.0/30, ubest/mbest: 1/0, attached
    *via 172.31.10.1, Eth1/1, [0/0], 01:41:01, direct
172.31.10.1/32, ubest/mbest: 1/0, attached
    *via 172.31.10.1, Eth1/1, [0/0], 01:41:01, local

Mutually, on NX03, we see that 10.1.1.1/32 was redistributed from IS-IS to OSPF (by default as E2):

NX03# show ip route
IP Route Table for VRF "default"
'*' denotes best ucast next-hop
'**' denotes best mcast next-hop
'[x/y]' denotes [preference/metric]
'%<string>' in via output denotes VRF <string>

10.1.1.1/32, ubest/mbest: 1/0
    *via 192.168.20.1, Eth1/2, [110/20], 01:39:49, ospf-10, type-2
10.2.2.2/32, ubest/mbest: 2/0, attached
    *via 10.2.2.2, Lo1, [0/0], 00:10:11, local
    *via 10.2.2.2, Lo1, [0/0], 00:10:11, direct
192.168.20.0/30, ubest/mbest: 1/0, attached
    *via 192.168.20.2, Eth1/2, [0/0], 01:40:02, direct
192.168.20.2/32, ubest/mbest: 1/0, attached
    *via 192.168.20.2, Eth1/2, [0/0], 01:40:02, local
Bilel

Bilel

0 0 votes
Article Rating
Subscribe
Notify of
guest

0 Comments
Inline Feedbacks
View all comments
Learn Duty
0
Would love your thoughts, please comment.x
()
x