Home>>Tutorials>>Out of band management configuration [Step by Step]
Tutorials

Out of band management configuration [Step by Step]

Topology:

In our topology, we have a Switch OOB connected to management interfaces on other devices and have a default gateway to Router 7200 (172.31.20.254/24):

In order to configure a basic out of band management network (OOB), follow the steps below:

Step 1: Configure Switch OOB interfaces:

interface Ethernet0/1-3

switchport access vlan 20

switchport mode access

Step 2: Configure interface vlan 20 in order to access the OOB switch remotely (on sw_OOB):

interface Vlan20

ip address 172.31.20.220 255.255.255.0

Step 3: Configure the default gateway of the OOB network (on sw_OOB):

ip default-gateway 172.31.20.254

Step 4: Configure OOB management addresses on the devices & static routes (or default route if you’re using a specific VRF for management interface) via the gateway which is the router C7200 in our case:

  • On cisco IOS: (3850)

interface GigabitEthernet0/0

vrf forwarding Mgmt-vrf

ip address 172.31.20.5 255.255.255.0

speed 1000

negotiation auto

ip route vrf Mgmt-vrf 0.0.0.0 0.0.0.0 172.31.20.254

  • On Nexus switch (Nexus 9000):

interface mgmt0

vrf member management

ip address 172.31.20.1/24

no spanning-tree vlan 1200

vrf context management

ip route 0.0.0.0/0 172.31.20.254

  • On IOS-XE switch (ASR1001-X):

interface GigabitEthernet0

vrf forwarding Mgmt-intf

ip address 172.31.20.251 255.255.255.0

negotiation auto

ip route vrf Mgmt-intf 0.0.0.0 0.0.0.0 172.31.20.254

0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments
Learn Duty
0
Would love your thoughts, please comment.x
()
x