Layer 2 vs Layer 3 Port Channel Interface


Port channel interfaces can be classified into L2 port-Channel and L3 Port-channel Interfaces.

L2 Port-channel Interfaces can be either:

  • Trunk
  • Access


L3 Port-channel Interfaces can be either:

  • Routed ports
  • Sub-interfaces


Basic configuration

Please refer to the following posts for Port-channel configuration on IOS and NXOS:


Example of Layer 2 Port-channel configuration

Switch(config)#interface range ethernet 1/2-3
Switch(config-if-range)#no switchport
Switch(config-if-range)#channel-group 1 mode active

Switch(config-if-range)#interface port-channel 1
Switch(config-if)# switchport
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk allowed vlan 15-20


Example of Layer 3 Port-channel configuration

Switch(config)#interface range ethernet 1/2-3
Switch(config-if-range)#no switchport
Switch(config-if-range)#channel-group 1 mode active

Switch(config-if-range)#interface port-channel 1
Switch(config-if)#no switchport
Switch(config-if)#ip address 10.50.1.1 255.255.255.252



For more deep dive, please refer to:

Bilel

0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x