Bridge Domain Interface (BDI): Explained & Configuration [Cisco IOS-XE]

Bridge Domain Interface (BDI): Explained & Configuration [Cisco IOS-XE]

This concept is very similar to BVI (which runs on Cisco IOS) but for devices running IOS-XE.

Below are some of the common terminologies used :

  • Bridge domain represents a Layer 2 broadcast domain.
  • Bridge domain interface is a logical interface that allows bidirectional flow of traffic between a Layer-2 bridged network and a Layer-3 routed network.
  • Ethernet Virtual Circuit (EVC) is an end-to-end representation of a single instance of a Layer-2 service being offered by a provider to a customer. In the Cisco EVC Framework, the bridge domains are made up of one or more Layer-2 interfaces known as Service Instances. A Service Instance is the instantiation of an EVC on a given port on a given router. Service instance is associated with a bridge domain based on the configuration.




BDI Configuration use cases:

– Use case1: Fa0/1 on both the switches are Layer-3 interfaces and are in the same broadcast domain:

Note: BDI interface configuration on ASR is not required if the motive is to just establish connectivity between the two switches.


ASR 1K:
======

interface GigabitEthernet1/2/3
no ip address
negotiation auto
cdp enable
service instance 100 ethernet
encapsulation untagged
bridge-domain 100

!
interface GigabitEthernet1/2/4
no ip address
negotiation auto
cdp enable
service instance 100 ethernet
encapsulation untagged
bridge-domain 100
SW1:
=====

interface FastEthernet0/1
no switchport
ip address 10.1.1.1 255.255.255.0
SW2:
=====

interface FastEthernet0/1
no switchport
ip address 10.1.1.3 255.255.255.0


We can verify by Pinging SW2 Interface Fa0/1 from SW1:

ASR1K#ping 10.1.1.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms


  • Note:

If you want to route outside of the ASR, a Bridge Domain interface (BDI) configuration is needed. To do this, configure a Bridge Domain Interface on the router using: “interface BDI100” command.


Bridge Domain Interface Configuration:

ASR1K# conf t
ASR1K(config)#interface BDI100
ASR1K(config-if)#ip address 10.1.1.2 255.255.255.0





– Use case2: Bridge multiple vlans between the two switches:

Configure separate Ethernet virtual circuits (EVC) under the physical interface for each of the VLANs. Bridge-domain is not supported under the sub-interface.

Here we have two VLANs. Vlan 100 and VLAN 200 to be bridged:


ASR 1K:
=======

interface GigabitEthernet1/2/3
no ip address
negotiation auto
cdp enable
!
service instance 100 ethernet
encapsulation dot1q 100
rewrite ingress tag pop 1 symmetric
bridge-domain 100
!
service instance 200 ethernet
encapsulation dot1q 200
rewrite ingress tag pop 1 symmetric
bridge-domain 200

! Exact same config under Gig1/2/4!

interface GigabitEthernet1/2/4
no ip address
negotiation auto
cdp enable
!
service instance 100 ethernet
encapsulation dot1q 100
rewrite ingress tag pop 1 symmetric
bridge-domain 100
!
service instance 200 ethernet
encapsulation dot1q 200
rewrite ingress tag pop 1 symmetric
bridge-domain 200
SW1:
====

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Vlan100
ip address 10.1.1.1 255.255.255.0
interface Vlan200
ip address 20.1.1.1 255.255.255.0
SW2:
====

interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Vlan100
ip address 10.1.1.3 255.255.255.0
interface Vlan200
ip address 20.1.1.3 255.255.255.0

Ping int vlan100 and vlan200 on SW2 from SW1:

BGL.Q.16-3500-1#ping 10.1.1.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms

BGL.Q.16-3500-1#ping 20.1.1.3

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.1.1.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms



More about EVC: https://community.cisco.com/t5/networking-documents/understanding-ethernet-virtual-circuits-evc/ta-p/3108219


The equivalent of BDI (IOS-XE platform) in IOS platform is Bridge-group Virtual Interface (BVI)

you can check Bridge-group Virtual Interface (BVI) in the article below:

Bilel A

Bilel A

0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments
Learn Duty
0
Would love your thoughts, please comment.x
()
x