vPC Configuration on Nexus Switches [Step by Step]

Note

A symmetric configuration will be configured on both Nexus-1 and Nexus-2.


Step-1: Enable vPC and LACP features:

NX-1(config)# feature vpc
NX-1(config)# feature lacp


Step-2: Configure vPC domain:

NX-1(config)#vpc domain 1


Step-3: Peer KeepAlive Configuration

Both management interfaces and SVIs can be used for peer keepalive links. The management interface and VRF management instance are the defaults and recommended.

configure terminal
interface mgmt 0
ip address 192.168.10.1 255.255.255.0
no shutdown
exit

peer-keepalive destination 192.168.10.2 source 192.168.10.1 vrf management


Verify KeepAlive is up via the command below:

show vpc peer-keepalive

Step-4: Configure vPC peer-link:

NX-1(config)# interface ethernet 1/10-11
NX-1(config-if-range)# description ## Peer-link ##
NX-1(config-if-range)# channel-group 10 mode active

NX-1(config)# interface port-channel 10
NX-1(config-if)# description ## Peer-link ##
NX-1(config-if)# switchport mode trunk
NX-1(config-if)# switchport trunk allowed vlan 1-100
NX-1(config-if)# vpc peer-link


Verify vPC status with the command below:

show vpc



Step-5: Configure vPC downlink Interfaces:

interface Ethernet1/1
  description ## Connected to Downstream Device ##
  switchport access vlan 50
  channel-group 20

interface port-channel 20
  switchport access vlan 50
  vpc 20
Bilel A

Bilel A

0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments
Learn Duty
0
Would love your thoughts, please comment.x
()
x