IPv6 static routes configuration [explained]

IPv6 static routes configuration [explained]

Why do we need Static routes:

Networking devices forward packets using route information that is either manually configured or dynamically learned using a routing protocol. Static routes are manually configured and define an explicit path between two networking devices.

Unlike a dynamic routing protocol, static routes are not automatically updated and must be manually reconfigured if the network topology changes. The benefits of using static routes include security and resource efficiency. Static routes use less bandwidth than dynamic routing protocols and no CPU cycles are used to calculate and communicate routes. The main disadvantage to using static routes is the lack of automatic reconfiguration if the network topology changes.

Static routes can be redistributed into dynamic routing protocols but routes generated by dynamic routing protocols cannot be redistributed into the static routing table. No algorithm exists to prevent the configuration of routing loops that use static routes.

Static routes are useful for smaller networks.



IPv6 Static routes types – Cisco :

Directly Attached Static Routes

Indirectly attached static routes, only the output interface is specified. The destination is assumed to be directly attached to this interface, so the packet destination is used as the next-hop address. This example shows such a definition:

ipv6 route 2001:DB8::/32 gigabitethernet1/0/0 

The example specifies that all destinations with address prefix 2001:DB8::/32 are directly reachable through the interface GigabitEthernet1/0/0.

Directly attached static routes are candidates for insertion in the IPv6 routing table only if they refer to a valid IPv6 interface; that is, an interface that is both up and has IPv6 enabled on it.

Recursive Static Routes

In a recursive static route, only the next hop is specified. The output interface is derived from the next hop. This example shows such a definition:

ipv6 route 2001:DB8::/32 2001:DB8:3000:1

This example specifies that all destinations with address prefix 2001:DB8::/32 are reachable via the host with address 2001:DB8:3000:1.



IPv6 static routing configuration example:


R1 configuration:

interface Loopback0
 no ip address
 ipv6 address FD00::4/64
!
interface FastEthernet0/0
 no ip address
 duplex full
 ipv6 address FC00:3333:2222:1111::/64 eui-64
!
ip forward-protocol nd
!
ipv6 route FA00::/64 FC00:3333:2222:1111:C802:13FF:FE0C:0



R2 configuration:

interface Loopback0
 no ip address
 ipv6 address FA00::8/64
!
interface FastEthernet0/0
 no ip address
 duplex full
 ipv6 address FC00:3333:2222:1111::/64 eui-64
!
ip forward-protocol nd

!
ipv6 route FD00::/64 FC00:3333:2222:1111:C801:4DFF:FE68:0


Verifications:

R1:

R1#show ipv6 int brief
FastEthernet0/0        [up/up]
    FE80::C801:4DFF:FE68:0
    FC00:3333:2222:1111:C801:4DFF:FE68:0
Loopback0              [up/up]
    FE80::C801:4DFF:FE68:0
    FD00::4
R1#show ipv6 route
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
S   FA00::/64 [1/0]
     via FC00:3333:2222:1111:C802:13FF:FE0C:0
C   FC00:3333:2222:1111::/64 [0/0]
     via FastEthernet0/0, directly connected
L   FC00:3333:2222:1111:C801:4DFF:FE68:0/128 [0/0]
     via FastEthernet0/0, receive
C   FD00::/64 [0/0]
     via Loopback0, directly connected
L   FD00::4/128 [0/0]
     via Loopback0, receive
L   FF00::/8 [0/0]
     via Null0, receive



R1#ping  FA00::8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FA00::8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/68/132 ms



R2:

R2#show ipv6 int brief
FastEthernet0/0        [up/up]
    FE80::C802:13FF:FE0C:0
    FC00:3333:2222:1111:C802:13FF:FE0C:0
Loopback0              [up/up]
    FE80::C802:13FF:FE0C:0
    FA00::8

R2#show ipv6 route
IPv6 Routing Table - default - 6 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, H - NHRP, I1 - ISIS L1
       I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary, D - EIGRP
       EX - EIGRP external, ND - ND Default, NDp - ND Prefix, DCE - Destination
       NDr - Redirect, O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1
       OE2 - OSPF ext 2, ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
C   FA00::/64 [0/0]
     via Loopback0, directly connected
L   FA00::8/128 [0/0]
     via Loopback0, receive
C   FC00:3333:2222:1111::/64 [0/0]
     via FastEthernet0/0, directly connected
L   FC00:3333:2222:1111:C802:13FF:FE0C:0/128 [0/0]
     via FastEthernet0/0, receive
S   FD00::/64 [1/0]
     via FC00:3333:2222:1111:C801:4DFF:FE68:0
L   FF00::/8 [0/0]
     via Null0, receive

R2#ping  FD00::4
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FD00::4, timeout is 2 seconds:
!.!.!
Success rate is 60 percent (3/5), round-trip min/avg/max = 40/41/44 ms





https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_pi/configuration/xe-3s/iri-xe-3s-book/ip6-route-static-xe.html



Read Also:

Bilel

Bilel

0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x