L2VPN VPLS Configuration Example Step by Step [Cisco CSR]
VPLS provides a full mesh multi-point to multi-point layer 2 networks.
Topology
MPLS Initial setup Configuration
CSR1 Configuration:
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet1
ip address 10.10.1.1 255.255.255.252
negotiation auto
mpls ip
!
interface GigabitEthernet2
ip address 10.10.2.1 255.255.255.252
negotiation auto
mpls ip
!
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
network 10.10.1.0 0.0.0.3 area 0
network 10.10.2.0 0.0.0.3 area 0
CSR2 Configuration:
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet1
ip address 10.10.1.2 255.255.255.252
negotiation auto
mpls ip
!
interface GigabitEthernet2
ip address 10.10.3.1 255.255.255.252
negotiation auto
mpls ip
!
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
network 10.10.1.0 0.0.0.3 area 0
network 10.10.3.0 0.0.0.3 area 0
CSR3 Configuration:
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet1
ip address 10.10.3.2 255.255.255.252
negotiation auto
mpls ip
no mop enabled
no mop sysid
!
interface GigabitEthernet2
ip address 10.10.2.2 255.255.255.252
negotiation auto
mpls ip
no mop enabled
no mop sysid
!
router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
network 10.10.2.0 0.0.0.3 area 0
network 10.10.3.0 0.0.0.3 area 0
VPLS Configuration
On CSR-1:
l2 vfi CustomerA manual
vpn id 111
bridge-domain 10
neighbor 2.2.2.2 encapsulation mpls
neighbor 3.3.3.3 encapsulation mpls
interface GigabitEthernet3
no ip address
negotiation auto
service instance 10 ethernet
encapsulation dot1q 110
bridge-domain 10
On CSR-2:
l2 vfi CustomerA manual
vpn id 111
bridge-domain 10
neighbor 3.3.3.3 encapsulation mpls
neighbor 1.1.1.1 encapsulation mpls
interface GigabitEthernet3
no ip address
negotiation auto
service instance 10 ethernet
encapsulation dot1q 110
bridge-domain 10
On CSR-3:
l2 vfi CustomerA manual
vpn id 111
bridge-domain 10
neighbor 2.2.2.2 encapsulation mpls
neighbor 1.1.1.1 encapsulation mpls
interface GigabitEthernet3
no ip address
negotiation auto
service instance 10 ethernet
encapsulation dot1q 110
bridge-domain 10