interface gi0/0
ip address 22.2.2.1 255.255.255.0
no sh
!
router ospf 10
log-adjacency-changes
network 22.2.2.0 0.0.0.255 area 0
interface Tunnel1
ip address 192.168.10.1 255.255.255.248
no ip redirects
ip nhrp map multicast dynamic
ip nhrp network-id 1
tunnel source 22.2.2.1
tunnel mode gre multipoint
!
Spoke-1 Router:
interface gi0/0
ip address dhcp
no sh
!
interface Tunnel1
ip address 192.168.10.2 255.255.255.248
no ip redirects
ip nhrp map 192.168.10.1 22.2.2.1
ip nhrp map multicast 22.2.2.1
ip nhrp network-id 1
ip nhrp nhs 192.168.10.1
tunnel source gi0/0
tunnel mode gre multipoint
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
Spoke-2 Router:
interface gi0/0
ip address dhcp
no sh
!
interface Tunnel1
ip address 192.168.10.3 255.255.255.248
no ip redirects
ip nhrp map 192.168.10.1 22.2.2.1
ip nhrp map multicast 22.2.2.1
ip nhrp network-id 1
ip nhrp nhs 192.168.10.1
tunnel source gi0/0
tunnel mode gre multipoint
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
ISP Router:
interface Ethernet1/0
ip address 22.2.2.2 255.255.255.0
no sh
!
interface Ethernet1/1
ip address 33.3.3.1 255.255.255.0
no sh
!
interface Ethernet1/2
ip address 44.4.4.1 255.255.255.0
no sh
ip dhcp excluded-address 33.3.3.1
ip dhcp excluded-address 44.4.4.1
!
ip dhcp pool POOL1
network 33.3.3.0 255.255.255.0
!
ip dhcp pool POOL2
network 44.4.4.0 255.255.255.0
router ospf 1
log-adjacency-changes
network 22.2.2.0 0.0.0.255 area 0
network 33.3.3.0 0.0.0.255 area 0
network 44.4.4.0 0.0.0.255 area 0
Configuration verifications:
HUB#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
44.4.4.1 1 FULL/DR 00:00:31 22.2.2.2 GigabitEthernet0/0
HUB#
ISP#show ip ospf neighbor
Neighbor ID Pri State Dead Time Address Interface
192.168.10.3 1 FULL/DR 00:00:38 44.4.4.2 Ethernet1/2
192.168.10.2 1 FULL/DR 00:00:37 33.3.3.2 Ethernet1/1
22.2.2.1 1 FULL/BDR 00:00:36 22.2.2.1 Ethernet1/0
ISP#
DMVPN Verifications:
On Hub Router:
HUB#show dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
N - NATed, L - Local, X - No Socket
# Ent --> Number of NHRP entries with same NBMA peer
NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
UpDn Time --> Up or Down Time for a Tunnel
==========================================================================
Interface: Tunnel1, IPv4 NHRP Details
Type:Hub, NHRP Peers:2,
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 33.3.3.2 192.168.10.2 UP 00:09:29 D
1 44.4.4.2 192.168.10.3 UP 00:09:39 D
On Spoke-1 Router:
Spoke-1#show dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
N - NATed, L - Local, X - No Socket
# Ent --> Number of NHRP entries with same NBMA peer
NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
UpDn Time --> Up or Down Time for a Tunnel
==========================================================================
Interface: Tunnel1, IPv4 NHRP Details
Type:Spoke, NHRP Peers:1,
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 22.2.2.1 192.168.10.1 UP 00:13:21 S
On Spoke-2 Router:
Spoke-2#show dmvpn
Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete
N - NATed, L - Local, X - No Socket
# Ent --> Number of NHRP entries with same NBMA peer
NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting
UpDn Time --> Up or Down Time for a Tunnel
==========================================================================
Interface: Tunnel1, IPv4 NHRP Details
Type:Spoke, NHRP Peers:1,
# Ent Peer NBMA Addr Peer Tunnel Add State UpDn Tm Attrb
----- --------------- --------------- ----- -------- -----
1 22.2.2.1 192.168.10.1 UP 00:14:24 S
Bilel-A
Enthusiastic Network Engineer specializing in Cisco ACI, passionate about solving challenges. A lifelong learner who loves gaining and sharing knowledge. Profile: https://www.linkedin.com/in/bilel-ameur-71116b2b5