xConnect L2TP over MPLS configuration [GNS3 Lab]

Topology



Configuration

CE-1 Configuration:

no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
l2tp-class LD-L2TPV3-CLASS
authentication
password Cisco12345*
!
ip tcp synwait-time 5
ip ssh version 1
pseudowire-class LD-PW-CLASS
encapsulation l2tpv3
protocol l2tpv3 LD-L2TPV3-CLASS
ip local interface Loopback1
!
interface Loopback1
ip address 10.10.11.1 255.255.255.255
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
no cdp enable
xconnect 10.10.12.1 100 pw-class LD-PW-CLASS
!
interface FastEthernet0/0
ip address 1.1.3.2 255.255.255.252
duplex auto
speed auto
!
router ospf 2
log-adjacency-changes
passive-interface FastEthernet0/1
network 1.1.3.0 0.0.0.255 area 0
network 10.10.11.1 0.0.0.0 area 0



CE-2 Configuration:

CE-2
hostname CE-2A
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
l2tp-class LD-L2TPV3-CLASS
authentication
password Cisco12345*
ip tcp synwait-time 5
pseudowire-class LD-PW-CLASS
encapsulation l2tpv3
protocol l2tpv3 LD-L2TPV3-CLASS
ip local interface Loopback1
!
interface Loopback1
ip address 10.10.12.1 255.255.255.255
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
no cdp enable
xconnect 10.10.11.1 100 pw-class LD-PW-CLASS
!
interface FastEthernet0/0
ip address 1.1.6.2 255.255.255.252
duplex auto
speed auto
!
router ospf 2
log-adjacency-changes
passive-interface FastEthernet0/1
network 1.1.6.0 0.0.0.255 area 0
network 10.10.12.1 0.0.0.0 area 0



PE-1 Configuration:

ip vrf Customer_A
rd 65000:1
route-target export 65000:1
route-target import 65000:1
!
interface Loopback1
ip address 10.10.13.1 255.255.255.255
!
interface FastEthernet0/1
ip address 1.1.1.2 255.255.255.252
duplex auto
speed auto
mpls ip
!
interface FastEthernet0/0
ip vrf forwarding Customer_A
ip address 1.1.3.1 255.255.255.252
ip ospf 2 area 0
duplex auto
speed auto
!
router ospf 2 vrf Customer_A
router-id 1.1.3.1
log-adjacency-changes
redistribute bgp 65000 subnets
!
router ospf 100
router-id 10.10.13.1
log-adjacency-changes
network 1.1.1.0 0.0.0.3 area 0
network 10.10.13.1 0.0.0.0 area 0
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 10.10.14.1 remote-as 65000
neighbor 10.10.14.1 update-source Loopback1
no auto-summary
!
address-family vpnv4
neighbor 10.10.14.1 activate
neighbor 10.10.14.1 send-community extended
exit-address-family
!
address-family ipv4 vrf Customer_A
redistribute ospf 2 vrf Customer_A
no synchronization
exit-address-family

https://www.gns3.com/marketplace/labs/mpls-l3-and-l2tp-lab

Bilel-A

Enthusiastic Network Engineer specializing in Cisco ACI, passionate about solving challenges. A lifelong learner who loves gaining and sharing knowledge. Profile: https://www.linkedin.com/in/bilel-ameur-71116b2b5
0 0 votes
Article Rating
Subscribe
Notify of
guest
0 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
0
Would love your thoughts, please comment.x
()
x